Router OpenWRT WR842ND DD-WRT almost bricked

Para dejar aquí todo tipo de bricos o de información de utilidad

Moderador: mbserran

Avatar de Usuario
mbserran
Administrador del Sitio
Administrador del Sitio
Mensajes: 7292
Registrado: 31 Mar 2015, 14:28
Ubicación: Aranjuez
Contactar:
Estado: Desconectado

Router OpenWRT WR842ND DD-WRT almost bricked

Mensaje por mbserran »

This morning I was poking with my router and I thought it would be a good idea to set up some static routes instead of the dynamic learnt ones (from RIP2). What a bad idea as I made a noob mistake. I put the route for all the same subnet of my router pointing to the main router as a gateway, which made my router completely unnaccesible from the web GUI. Everything that was trying to reach my WR842ND IP was redirected to my main router's IP and this resulted in a nightmare.

I got into several pages on how to get into fail safe mode in my WR842ND router but without any success. And after a lot of fighting I fnally found a very smart and simple solution that for this specific case works. I put you here just in case you have a similar problem.

I thought that the problem was the redirection, so I started the network normally and then I disconnected all ethernet cables but just the one of the PC that is directly connected to the WR842ND. If you do not have any just connect one directly. This PC had its own valid IP but a changed it manually to the one of the gateway (cheating the WR842ND to think that my PC was the main router). And it worked!! I got access again to the GUI of the WR842ND in that PC, as everything was redirected to it.

All I had to do is to change the settings in the GUI again back to the previous state. And that's all. Easy and quick, but a nightmare if you do not pay attention to this trick.

Hope it helps if you are in a similar condition!!
Responder